Go Back  Bike Forums > Bike Forums > General Cycling Discussion
Reload this Page >

Anyone have this problem with Edge 1030

General Cycling Discussion Have a cycling related question or comment that doesn't fit in one of the other specialty forums? Drop on in and post in here! When possible, please select the forum above that most fits your post!

Anyone have this problem with Edge 1030

Old 05-18-18, 04:43 AM
  #1  
Ald1 
Senior Member
Thread Starter
 
Join Date: May 2017
Location: Central Pa.
Posts: 230

Bikes: Domane SLR 9 Fuji Gran Fondo 2.3 1978 Mercian

Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Likes: 0
Liked 2 Times in 1 Post
Anyone have this problem with Edge 1030

OK. I should have listened about the glitchy garmins, as the time this thing works is less than when it does not. Anyway the one issue I would like to resolve is, after about 15-20 minutes of riding,my heart rate (Polar) freezes at usually 116 or 156 BRM. It still shows connected. Even though I disconnect and tell the 1030 to forget the sensor the heart rate still is there and static. I need to remove the battery in the monitor to get rid of the freeze. WTF? I DO NOT have this problem with the wahoo kicker and this HR monitor so I know it's the Garmin Thought I'd check here to see if anyone else has this bug. Calling Garmin today and will try a reset. The big problem with this is it looks fine at start of ride. Such a big company like Garmin you would think they would put more resourses in the bicycling products and stability as again I've seen too many posts on the bugs!!!
Ald1 is offline  
Old 05-18-18, 08:49 AM
  #2  
pdlamb
Senior Member
 
Join Date: Dec 2010
Location: northern Deep South
Posts: 5,103

Bikes: Fuji Touring, Novara Randonee

Mentioned: 25 Post(s)
Tagged: 0 Thread(s)
Quoted: 924 Post(s)
Liked 12 Times in 9 Posts
I had this problem with a Garmin strap in cold weather. New battery worked for a while, and some sort of gel might work.

Wahoo strap has worked flawlessly on my Garmin since then.
pdlamb is offline  
Old 05-19-18, 07:51 PM
  #3  
Ald1 
Senior Member
Thread Starter
 
Join Date: May 2017
Location: Central Pa.
Posts: 230

Bikes: Domane SLR 9 Fuji Gran Fondo 2.3 1978 Mercian

Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Likes: 0
Liked 2 Times in 1 Post
Thanks. Just got a Wahoo HR monitor so we'll see if that does better. Used it indoors with the Garmin today on a trainer and it did fine. No freezing.
Ald1 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.