Go Back  Bike Forums > Bike Forums > Electronics, Lighting, & Gadgets
Reload this Page >

Garmin Edge 705 lost mapping

Notices
Electronics, Lighting, & Gadgets HRM, GPS, MP3, HID. Whether it's got an acronym or not, here's where you'll find discussions on all sorts of tools, toys and gadgets.

Garmin Edge 705 lost mapping

Old 10-30-16, 07:59 AM
  #1  
Metal Man
Senior Member
Thread Starter
 
Join Date: Nov 2008
Posts: 353
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Likes: 0
Liked 2 Times in 2 Posts
Garmin Edge 705 lost mapping

I have an Edge 705 that the mapping used to work, now it doesn't. When I push menu-where to-find places the only options are Favorites and Cities.
I can't see how it would have caused anything, but I first noticed this after I replaced the battery. I have replaced the SD card with a new one from Gamin with no change.
I also just did an update on it again with no change.
Any help is appreciated.
Metal Man is offline  
Old 01-09-17, 08:40 AM
  #2  
Metal Man
Senior Member
Thread Starter
 
Join Date: Nov 2008
Posts: 353
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Likes: 0
Liked 2 Times in 2 Posts
Nobody has any thoughts on this?
Metal Man is offline  
Old 01-09-17, 09:30 AM
  #3  
rm -rf
don't try this at home.
 
rm -rf's Avatar
 
Join Date: Jan 2006
Location: N. KY
Posts: 5,304
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 727 Post(s)
Liked 116 Times in 85 Posts
I didn't see your original post. I don't think there's any way to turn off the maps, so something isn't working correctly. I replaced my 705 battery, and that didn't cause any problems for me.

Plug it in with the USB cable. On Windows, my 705 shows as Garmin (E : ) and Garmin4GB (F : ). I think I renamed the 4GB card to make it easier to see which drive is the 705, and which is the card.

The map file
On the card, you need a file named
gmapsupp.img
in the folder named GARMIN

need a new file? garmin.openstreetmap.nl/

Years ago, I downloaded the eastern US file (2GB in size) and renamed it to gmapsupp.img, and copied it to the 4GB card.

Try scan and repair

Right click the drive letter, select Properties-->Tools. Click Error Checking. It may say "you don't need to scan this drive, we haven't found errors" but click Scan and Repair. It'll take a minute to finish. It'll either say it's okay, or list the sectors it repaired.

I used to have to do this regularly on the base 705 drive, or I'd get occasional mangled ride recordings. It seems to be better now (maybe with the new battery?) I've never needed to scan the 4gb card, since it only holds the map file.
rm -rf is online now  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jef.engers
Electronics, Lighting, & Gadgets
52
01-11-17 09:17 AM
hobkirk
Road Cycling
3
08-31-14 09:48 PM
bubbies
Electronics, Lighting, & Gadgets
1
09-21-13 07:47 PM
CanadianBiker32
Electronics, Lighting, & Gadgets
2
06-21-13 07:09 AM
M_Wales
Road Cycling
4
09-13-12 10:04 PM

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.